720World will be shutting down at the end of 2020.  Please see the announcement in the Forums.  No new members are being accepted at this time.  Thanks for all the support over the years, and happy trails.


Little Trucks, Big World

Ok, here's the gist.

I went to Lowe's to pick up some stuff with the truck and made a few stops along the way.   At each stop my truck started easily and off I went, then at Lowe's I pulled into a spot and turned off the truck to go in.   I realized the bushes next to me would not allow my door to open enough and decided to move to the other side of the little median (i like to protect any vehicle I drive by parking at a curb spot) but when I went to start the truck I heard a quick *bzzzzz-pop* and then everything was dead!?

I tried to restart it but everything was done, no radio, no gauges, nothing.    First thing I thought was "fuse", checked the box and pulled out the ignition fuse and tada...it popped.    I replaced the fuse but to my disappointment, still nothing at all...hmmm.    I popped the hood and checked all around the fusible link-all good, then removed the battery and checked all the wiring around it-no problem, then the alternator, etc. and could not find any issue with a wire that had either melted, discolored, or showed signs of rubbing against metal and causing a short.

I then took apart the steering column and checked the wiring around the ignition, pulled off the harness and checked the contacts and could not find any issue, at least not in the parking lot of a Lowe's with minimal tools to work with.

Basically, it was getting later and I wanted to just get the truck home to figure it out and decided to call for a flatbed to get me home.   I decided to put the battery back in for now.  On a whim I thought..."maybe I'll try hitting that key one more time", when I did...everything came on again and it started right up...what the heck?

Not wanting to risk it, I headed for the house just so i could have it there to work on.  I got home safely, turned it off and after a minute tried to start it again and had no issue at all.

Anybody have anything like this happen before?  The only thing I could think of is that when it popped in the first place it possibly hung a relay in the open position and in all the time it took me to do some investigating and remove, then replace the battery, it possibly closed again and completed the circuit for it to start again.    I don't know if this is a plausible conclusion but it's the only thing I can think of to make sense of it.

I have had all kinds of things happen with this truck over all the years I have owned it but this is a first for me, I have never had this happen in any vehicle I have ever owned.

By the way, I have not had any electrical issues with this truck at all and it never blows fuses but as a precaution, when I restored it I replaced all the fuses in the block with new ones.   I wondered if that fuse was just not good to begin with and that was why it blew?  Don't know.

I would appreciate any help on this, especially if you have ever experienced it yourself.



Views: 182

Reply to This

Replies to This Discussion

I've had a similar issue. It was the main EFC relay. They can get water in them as they get old and the plastic case starts to deteriorate or the plastic housing on the connector breaks apart or just not making good contact at the pins.. Sometimes just wiggling it will get it to work but replacing it is the best option. Not easy to find them these days though...

Thanks for the reply, it's funny you mention it because I actually replaced that exact relay back when I was rebuilding the truck.

Problem is, it's the harness itself that has deteriorated terribly over the years.  It's brown, crusty, dry, and falling apart, which is strangely opposite of all the other harnesses on my truck which look very good.

I always wanted to replace it with a better/new one but could never locate one, not a surprise.

I drove the truck all over today with no issues at all.

Any ideas on doing something better and more durable with it?

I think it's location near the battery, and the fact that it stays energized any time the key switch is on is what leads to problems with this relay, connector and wiring.

I don't have any work-arounds for this.  What I've done is cut out the plug and replaced it with another from a junk truck or simply replaced the relay itself. Over the years I've always pulled the relays out of any 720 I can find in the yards just so I'd have them when I need them and have cut them out with the plugs.  Unfortunately, there aren't as many around as there once was and my supply is dwindling...

I will look into this and see if I can find a more commonly available relay/connector which could be wired in to take it's place.

Thanks.   I'm running into the same issue here as far as supply goes.   I know of only one truck in a 50 mile radius that I'm at least "aware" of.   I have called many yards locally and they all say "I haven't seen one of those in quite a while".   So unfortunately these trucks get harder and harder to replace old parts with since not only is the supply dwindling, but aging faster than those that are cared for and driven.

Btw I don't recall if I ever told you but I have two Mazda 6's.  the 2013 Grand Touring I currently drive just took the place of my 2012 that had just reached 250K miles on it when it started losing compression in a few cylinders...  I loved it so much I bought another one the exact same color lol...  I have the 6i though but always looking for ms6.  I've toyed with putting the 4 cylinder Mazda into a 720.  it has some balls lol.  I still have the 2012 though I have it loaned to a friend it still runs good just keeps throwing misfire codes and cyl 2 is very low on compression prob a valve or valve seat I'd guess.  No signs of a blown head gasket.

I didn't know that, but that's pretty awesome.

obviously, by my forum name, I had a Mazdaspeed 6 at the time and really loved it, but it came down to a house or the car, soo....

I had the first year and it had some teething pains but Mazda took care of me and It stayed pretty reliable after that.

I bought a '96 Maxima 5 speed for an interim car because I heard such good things, honestly had nothing but constant issues with it and spent too much money keeping it going.

Since then, I bought an '07 Mazda Miata touring (manual like all my vehicles) and absolutely love it, the thing is just a blast to drive anytime but especially on a curvy back road.

Yeah I never owned a Mazda before the 2012 6.  So I had no idea of what to expect.  It was the most problem free car I've ever owned.  250,000 miles without ever an engine problem of any kind.  The only thing you have to put up with is wheel bearings going bad every 40-50k miles lol.  But that seems the norm these days with any brand, them using ball bearings for wheel bearing which is something they were never intended to be used for...  And they are right, Mazdas are built for people who love to drive.  And I bet that Miata is a blast, but I don't think I'd fit in one very well lol...

Oh, I don't know...I bought my NC (3rd gen.) because it IS a little bigger than the others.    I am 6ft. tall and 210lbs., I have no issue fitting in it.    

All the other versions (NA, NB, and ND) don't fit me.

The others love to give the 3rd gen. a lot of crap for being bigger, but it's faster, rides far better, corners just as well, and has more room with only a minimum weight gain over the NB and also has more power by quite a bit.

The only thing I have had to do in 80k miles was replace the clutch slave cylinder.    It has a six speed manual with short gearing so I do a lot of shifting and that little slave cylinder wears out over time.   I decided to replace the clutch master cylinder, slave, and the lines with braided for better, more reliable clutch feel.   

If you're going in you might as well do it all at one shot.

I was looking over the circuitry for this relay last night.  It's a DPST relay which isn't a very common configuration for relays.  It's controlling power to the carb electronics (fuel air solenoid and the anti-dieseling solenoid), and power to the ECC using two separate fusible link feeds.  It's like two single pole/single throw relays in one package with a shared coil.

I believe it's the same relay as the A/T inhibitor relay.

Anyway, its not easy to source a direct replacement because it's such an oddity.  However, it could be replaced with two SPDT relays.  You'd just wire a jumper between the two coils and use one relay for the ECC, and one for the carb electronics.  It could also be replaced with a single DPDT relay using only the NO contacts, however most of those are way oversized in amperage for this application and as a result are physically very large...


Two Bosch type SPDT relays would likely be the way to go.  You would also only use the NO contacts on these.  85/86 is the coil and 30/87 are the NO contacts.



That's interesting, I only have one located on the fender near the battery, and it' looks the same as your pic. on the bottom.

I have not seen the relay on top unless it is located "in the cab" instead.

I should note that I have a Weber carb and no longer run a majority of the components that the stock set up did, just an electric choke and idle cut off solenoid.

Here is a recent update on this issue.   After the initial issue it did not come back and the truck has started and ran perfectly fine....until today.

I had started it up last week to let it run a bit and charge the battery, circulate the fluids, etc. 

After about 10 minutes of idling I heard a whistling noise and upon checking it out I came to the assumption that I had a vacuum leak that needed attention.

I decided to check the intake manifold bolts and the carb. for any were loose and possibly causing the issue, upon finishing that up I decided to crank it up to do a test to see if I fixed it or not.   Upon trying to start it, the radio came on, fuel pump came on, and when I turned the key it made a quick bzzzzt (like a short?) and everything was dead again.

I disconnected the battery like before, removed and cleaned up the solenoid attached to the right inner fender along side the battery and did not see any issue.   Plugged the battery back in and everything came back on again, turned the key and bzzzzt...dead again.     That is where I quit and packed it in for the night.

Do we have any ideas on this one?    Puzzled and I don't want it to strand me somewhere again.

Is their any chance that the starter solenoid is causing this issue since it is every time I turn the key to the "start" position?  Either that or something to do with the ignition itself?   Grasping at straws here.


© 2020   Created by TigerRacing.   Powered by

Badges  |  Report an Issue  |  Privacy Policy  |  Terms of Service