720World

Little Trucks, Big World

Hey y'all, figured I'd throw this out here and see if I could get any leads. 85 720 King Cab 4x4 with carb Z24, 5-speed manual. Engine and carb were rebuilt around three years ago by previous owner.

When driving in any gear, if you give it a good amount of gas on an incline or floor it while flat, you'll get varying amounts of knocking/pinging/detonating/static, whatever you want to call it, coming from up front. Only happens when giving it gas. Sometimes it doesn't do it at all, but if you're in 5th gear on a slight incline at 2400-3000 RPM, it is pretty bad. It will disappear once you hit a certain RPM, around 3200-3400 I'd say.

I've done standard tune-up stuff, cap, rotor, plugs, wires, all good. I've read up a bit on detonation. Could be timing, compression, or something as simple as the gas, plugs, or lugging the motor.

Any tips would be great!

Views: 41

Reply to This

Replies to This Discussion

Try using 93 octane gas,I use it or mine will ping.

This could be a lot of different things...  You're leaning out more than likely, the why may take some troubleshooting...

Do you still have the EGR valve in place and functioning?

Did you check your base timing with the vacuum line removed from the distributor and plugged?

Have you tried cleaning your carb with carb spray and/or adding a fuel treatment?

Corey

Has this been a recent change?   You may also want to think about any recent changes to the truck that may have caused this as well, maybe a change in places you buy fuel....it's amazing what a little bad gas can do but I don't know how long you have had this issue either.

As Corey said, I would also look at your timing, that is where my trucks problems related back to.   Once I set the timing properly and adjusted the carb. to the correct settings it has run better than it has in years.

Thanks for the responses. After doing a standard tune-up, I replaced the fuel filter and pump filter and have been running premium 93 for around a month. Also checked my timing, it was spot on. I have not checked the EGR yet, but I have no more pinging!

Here's how to check your EGR,place your finger under the valve and feel for free movement by pushing up,be sure to wear gloves if there is any danger of being burned by hot components near the EGR valve.If it doesn't,replace the EGR valve.Now start the engine and run at idle speed.While the engine is still beginning to warm up,again push upward on the EGR diaphragm with your finger,the engine should loose speed,stumble or even stall.If the engine  did not change speed,the exhaust gas pipe leading to the EGR valve should be checked for blockage.

RSS

© 2019   Created by TigerRacing.   Powered by

Badges  |  Report an Issue  |  Privacy Policy  |  Terms of Service